Announcement

Collapse
No announcement yet.

JOGL 2.3.2?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • JOGL 2.3.2?

    Hi all,

    Seems we are always fighting an issue where some part of our user base can't run WW. The latest looks to be some machines that became unable when we moved from vanilla 2.1.4 libs to the 2.1.5 libs that the WW distro includes.

    Since typically the solution seems to be to upgrade, has anyone run WW with the latest JOGL, 2.3.2?

    I'm also a little concerned about webstart, I thought the libs included with the WW distro had been post-processed in some way to work better with webstart.

    Thank you

  • #2
    hi.

    their are known issues in MacOS support, which have allready been fixed in 2.2.x
    so at least this would be good to have :-)

    anyone knews if this might work?
    @WWJ:Team any plans to update this from your side?

    cheers

    -marco

    Comment


    • #3
      Hi

      I'm also wondering if an update is in the pipeline? There seems to have been a namespace change for all JOGL objects in 2.2 -- see https://jogamp.org/bugzilla/show_bug.cgi?id=682. So, if I have a project using 2.3.2, it does not seem to be compatible.

      Thanks
      -- Shitesh

      Comment


      • #4
        Yep! Good call! You will see it tomorrow!

        Comment


        • #5
          I like to use WWJ with ARM Linux 64 bit. JOGL 2.1.5 does not support aarch64. Is WWJ with JOGL 2.3.2 available?

          Comment


          • #6
            Originally posted by Mali Karl-Heinz View Post
            I like to use WWJ with ARM Linux 64 bit. JOGL 2.1.5 does not support aarch64. Is WWJ with JOGL 2.3.2 available?
            I'd also still really like to see this. However, I've found that the latest JOGL before the namespace change was 2.2.4, and that seems to work fine with WorldWind, if that helps.

            Comment


            • #7
              Thank you for your hint of version 2.2.4 but ARM 64bit support starts with JOGL 2.3.0.

              Comment


              • #8
                Hello,

                Please check out this pull request: https://github.com/NASAWorldWind/WorldWindJava/pull/1

                The pull request isn't an official version and isn't produced by the WorldWind team, but, I believe it works and provides JOGL 2.3.+
                Zach
                World Wind Team
                https://github.com/NASAWorldWind

                Comment

                Working...
                X