Announcement

Collapse
No announcement yet.

Limited user on Windows XP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Limited user on Windows XP

    How can I install World Wind? Google gave me an advanced option for installing Earth for limited user; could you give such an option, too? Please!

    :Maybe try installing outside the Program Files or in your user folder...

    ::It doesn't offer to. It just gives out the message about Administrator privileges required.
    ::Looking for more help from you.

    :::I see the problem, but OTOH what would be the purpose of a limited account if everything can be installed (just in another folder)?

    ::::Limited account is recommendation of Microsoft. It can stop programs at least from damaging system files and such programs as Notepad. You can also read this: http://windows.microsoft.com/en-us/w...trator-account

    :::::"if you want to do something that affects other users of the computer, such as installing software [...] Windows might ask you to provide a password for an administrator account" and this is the case with the WW installer - just right click and run as administrator, after that it will install without problems
    :::::and please use the forums (not http://worldwindcentral.com/wiki/Tal..._Wind_Download) next time to get answers to such questions

    ::::::I do not want to affect other users of the computers; I want to install World Wind for one user.

  • #2
    You just need to copy the ww executable directory to somewhere that you can write to. It should run from just about anywhere. The problem you are going to have is that you need a specific version of the directX libraries, and .Net Framework 2.0. If those aren't on the computer, it won't work.
    James

    Comment


    • #3
      BTW You can use 7-zip to open the installer exe (it's made with NSIS) and extract files from there.
      Hot stuff: FAQ, forum search, DirectX, .NET, Video Card Compatibility list

      Comment


      • #4
        Thanks for your help...and explain more, please!

        Originally posted by m_k View Post
        By The Way, you can use 7-zip to open the installer exe (it's made with NSIS) and extract files from there.
        I have successfully installed 7-zip

        and extracted World_Wind_1.4.0_Full.exe to a folder on my computer,

        but WorldWind.exe refuses to run ("NASA World Wind has encountered a problem and needs to close. We are sorry for the inconvenience.")

        and I suppose that folders "$HWNDPARENT", "$PLUGINSDIR" and "$TEMP" should be moved somewhere else, into another directory.

        Where should I move the folders

        or

        what should I do to persuade WorldWind to be portable and use them from where they are now?

        Thank you for advice
        waiting for more...

        P.S. I suppose I have both DirectX 9.0 and .NET Framework (versions 2.0 and 3.5).

        Comment


        • #5
          That error means that probably you don't have DX or .Net installed. WW requires Managed DirectX (see the link in my sig - newer version should be fine too).

          "$HWNDPARENT", "$PLUGINSDIR" and "$TEMP" those are folders used only by NSIS, there shouldn't be any important WW files.
          Hot stuff: FAQ, forum search, DirectX, .NET, Video Card Compatibility list

          Comment


          • #6
            Thanks again!

            Originally posted by m_k View Post
            That error means that probably you don't have DX or .Net installed. WW requires Managed DirectX (see the link in my sig - newer version should be fine too).

            "$HWNDPARENT", "$PLUGINSDIR" and "$TEMP" those are folders used only by NSIS, there shouldn't be any important WW files.
            After DirectX installation (February 2007 version) WorldWind opened!

            But the screen is black, there is no planet on it. What's the problem?

            Comment


            • #7
              Do you see Landsat and USGS icons on the toolbar, do you have Images in the layer manager?
              Hot stuff: FAQ, forum search, DirectX, .NET, Video Card Compatibility list

              Comment


              • #8
                Nothing is seen

                Originally posted by m_k View Post
                Do you see Landsat and USGS icons on the toolbar, do you have Images in the layer manager?
                I don't see layer manager. I don't see any icons. I suppose I see no toolbar.

                I only see "File Edit View Tools Plug-ins Help".

                I turn on/off the toolbar and layer manager in "View" menu but nothing changes.

                Comment


                • #9
                  Now I'm getting angry on 7z for working not well enough

                  Originally posted by m_k View Post
                  That error means that probably you don't have DX or .Net installed. WW requires Managed DirectX (see the link in my sig - newer version should be fine too).

                  "$HWNDPARENT", "$PLUGINSDIR" and "$TEMP" those are folders used only by NSIS, there shouldn't be any important WW files.
                  "$HWNDPARENT", "$PLUGINSDIR" and "$TEMP" do contain important WW files!
                  "$TEMP" seems to contain mdx-oct-2005.exe --- a DirectX installer?
                  Occasionally, it came to my head to move content of "$HWNDPARENT" to WW directory - and I began to see the stars, the globe, boundaries of countries, etc.
                  Then "$PLUGINSDIR" to plugins...
                  Unfortunately, I don't see the images: the globe is black due to absence of imagery.
                  But I do see the Moon and other planets quite well!

                  Your forum displays a sent message only after several hours. I don't have enough patience to wait for my previous message to be shown.

                  Comment


                  • #10
                    When you first run WW, a directory will be created under your profile, in \Application Data\NASA\World Wind\1.4.0.0. There should be two xml files created in there. WorldWind.xml and World.xml. You might have to correct the paths in either of those to point to your executable loaction. Especially the config path and data path entries in the worldwind.xml.

                    Comment


                    • #11
                      Sorry for the "$FOLDERS" confusion - I didn't check the installer, I only wrote what I remembered about NSIS.

                      You can see something (stars, boundaries) that's a good sign If you zoom closely, do you see new layers (Landsat) appearing?
                      Also - check Plugins->Load/Unload and see if BMNG Loader is loaded and active at startup.


                      There is a delay in your posts because you're not registered. Everything you post must be approved by one of the moderators. They don't work here 24/7...
                      Hot stuff: FAQ, forum search, DirectX, .NET, Video Card Compatibility list

                      Comment


                      • #12
                        The paths were and are correct, as it can be concluded from seeing Moon, Mars, etc.

                        Originally posted by m_k View Post
                        Sorry for the "$FOLDERS" confusion - I didn't check the installer, I only wrote what I remembered about NSIS.

                        You can see something (stars, boundaries) that's a good sign If you zoom closely, do you see new layers (Landsat) appearing?
                        Also - check Plugins->Load/Unload and see if BMNG Loader is loaded and active at startup.

                        There is a delay in your posts because you're not registered. Everything you post must be approved by one of the moderators. They don't work here 24/7...
                        I don't see LandSat and ZoomIt! appearing because their images should be downloaded from the Internet during installation; now it should be done manually; how?
                        But the strange layer "Images" does show some irregular imagery on zooming in: it's patched as a carpet and disappears on zoom out.

                        There is no BMNG loader in list of plug-ins.

                        How can I show you a screen-shot of my WW?

                        Comment

                        Working...
                        X