No announcement yet.

Update/Fix for World Wind 1.4.0 Imagery and Terrain

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Update/Fix for World Wind 1.4.0 Imagery and Terrain

    Updates to fix data layers and terrain in World Wind 1.4.0.

    Data fix only

    This will fix the data layers, but not the terrain. It doesn't replace any program files. It replaces the relevant *.xml files and installs local Base Images, Placenames and Borders.

    Jupiter and Venus include low-resolution base images, with download links to the full high-resolution add-ons. The rest of the solar system has been added, as well.

    World Wind 1.4.0 Data Fix

    Data and terrain fix

    This includes the data fix above, James_In_Utah's recompilation of the 1.4.0 source code, and maleport's terrain fix (for Earth).

    It doesn't currently have terrain for the Moon and Mars, but hopefully it will at a future time.

    World Wind 1.4.0 Fix

    These have been tested by performing a fresh install of World_Wind_1.4.0_Full.exe, followed by installation of one of the fixes above. You don't need both.

    It also seems to work on existing installations with lots of add-ons/plugins, but some things might get broken, so back up your existing installation.

    After installation, go to Load/Unload Plug-ins and turn off BmngLoader (uncheck the autostart box) and restart World Wind.

    Lunar Elevation Cache Pack

    This is the first four levels of lunar terrain tiles from the old server.


    To view all my addons visit

  • #2
    We probably need to get this thread made sticky. Who has the power to do that?


    • #3
      Hot stuff: FAQ, forum search, DirectX, .NET, Video Card Compatibility list


      • #4

        I found that a member asked same question in this forum some months ago.

        Pls use search box to find this questions with comments


        • #5
          Thanks for the update

          Whoa! Thank You. I'd almost given up on WW, as I'm not Java literate and .net seemed be imitating a Norwegian parrot, with even the servers vanished


          • #6
            Uddate Imagery and Terrain Fix Compatibility Issues

            Thank you so very much for the 1.4.0 data layers/terrain fix. I had all but given up on WW.

            I found that it works great on XP.

            In vista it only works if after loading a fresh copy of 1.4.0 and the imagery/terrain fix I then load the old pre 1.4.0 patch. Imagery then works but there is no terrain elevation.

            If I do not load the old 1.4.0 patch, WW crashes when loading.

            I have tried this on two machines with the same results.

            Do you have any suggestions?

            Thanks again!


            • #7
              Problem with 1.4.0 data layer/terrain fix??

              Thank you so very much for the 1.4.0 data layers/terrain fix.
              I had all but given up on WW.

              I found that it works great on XP.
              However In vista it crashes.

              I discovered that after loading a fresh copy of 1.4.0 and the imagery/terrain fix, if I then load the old “pre 1.4.0 patch”, it loads without crashing but there is no terrain elevation.
              I have tried this on two machines with the same results.
              Do you have any suggestions?


              • #8
                Problems on 64bit Win7 systems

                Issues with James_in_Utah's recompiled source code.

                I have two systems, both Windows 7 64bit versions, that do not like James' recompiled binary files. I have tested this by 1) installing normal World Wind 1.4.0 and running it (runs fine but is useless), 2) installing Data+Terrain fix which also contains the recompiled binary and it immediately does not work when trying to run World Wind (worldwind.exe). I receive an immediate error message the World Wind does not run and it attempts to locate a solution online. I have a feeling it's .net related because I see a .net error process start up immediately upon running World Wind (i.e. almost like a Dr. Watson for .net). I also have Windows XP 32bit and Windows 7 32bit systems which both work flawlessly with the Data+Terrain fix. My conclusion is that the new binary files that James compiled are somehow not 64bit compliant, or at least not as compliant as the original 1.4.0 binary files.

                I imagine that it's just the 'worldwind.exe' file that needs to be recompiled. Is there any way that James could recompile his modified code in such a way that 64bit architecture flags are set and pass along the newly compiled EXE? Alternatively, could I get a copy of the modified code to try compiling myself? If there's anything I can do to help I'd be happy to assist.



                • #9
                  Most triumphant and excellent !!! Wow.

                  Great work and much thanks from the .Net faithful.
                  (The few, the stubborn.)


                  • #10
                    First and foremost, thank you greatly for the update. It's working well on my 32bit systems. Cheers!

                    Last, unfortunately it does not work well on my Windows 7 64bit systems. In fact, it doesn't run at all on these systems.

                    Clarification: I can install and run the standard World Wind 1.4.0 without either of the new patches. However, if I install the Data+Terrain Fix then World Wind will no longer run - I get an immediate program crash and message that it's looking for a solution online. I believe the issue lies in the newly compiled World Wind.exe binary provided by James_in_Utah. Has anyone reported this issue?

                    I would be happy to do some testing of new builds if needed, and would even be okay with compiling my own from James' modified source if it were available. Let me know how I can help resolve this issue for 64bit system users with the Data+Terrain Fix.

                    Thanks again for the server fixes on this deprecated software.


                    • #11
                      'TesterAlso' is me prior to registering for the forum. Sorry for the duplicate post.


                      • #12
                        Regarding building for 64-bit. I don't have a 64-bit OS to test on. I did the build with VS 2005. I'll look to see if I can find any compiler options addressing 64 bit compatibility. If anyone has a suggestions on what to look for that would be appreciated.


                        • #13

                          Thank you very much for looking into this and helping to keep WW1.4.0 alive and going. Pangloss, maleport, and your efforts are greatly appreciated by me and I'm sure many others. I'd be glad to assist with whatever I can.

                          To start, here are a couple links to pages that contain information specifically on compiling for 64bit systems and how you might go about doing that.

                          When compiling C++ code for .net applications (I think we are, correct?), you can use a compiler options of '/clr:safe' to compile an agnostic binary that will run in 64bit and 32bit depending on system that's running it. There are some caveats to this but since the original WW1.4.0 doesn't not contain any special 64bit binaries then there must be a way to compile a single EXE that will correctly run on both architectures.
                          Source: (see Compiler support for creating 64-bit applications)
                          Source: (see Remarks / Safe and Pure Images)

                          Additionally, by default, the 64bit compilers are not installed on 32bit system, but you can manually install them.
                          Goto Add/Remove programs, select Visual Studio, Change, Add/Remove features and add x64 compilers from C++ node. After installing x64 compilers, you should see appropriate options under Platform and shoudl be able to build x64 projects on 32 bit machine.

                          I don't know how much you changed or added in (by way of dlls), but if it's minimal then the solution may just be a simple recompilation having the 64bit compiler options installed and/or using the /clr:safe agnostic compiler flag turned on.

                          I don't know but perhaps a simple test would be to compile the vanilla WorldWind 1.4.0 code on your system without any changes to either the code or your VS2005 install, and then test that new EXE on a clean install of WW1.4.0 on a 64bit system just to see if it throws the error. If it does, then take the next step of installing the 64bit compiler additions to VS2005, recompile the vanilla code, and test on 64bit system again. If it throws the error again, then take the next step of adding the /clr:safe compiler flag, recompile the vanilla code, and test yet again on a 64bit system.

                          If at any point you/we can get the recompiled binary working on a 64bit system then add back your changes to the source code and try the compile again to see if the new binary works on 64bit systems.

                          I hope this is helpful and not overwhelming. I also hope this doesn't take too much of your time. Thanks again for your help with all of this.


                          • #14
                            I'm not sure if my install of VS 2005 can do that. I looked around in the build options and didn't see any reference to that flag. I also tried just typing it in on the additional compiler directive box, which threw a warning saying it was invalid and would be ignored. Maybe we should try to find out who built the official release.


                            • #15
                              I don't know if it helps any, but a lot of this was discussed in the IRC channel.

                              To view all my addons visit