No announcement yet.

WorldWind Compiling Guide Without Visual Studio

This is a sticky topic.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The version they had handy?

    Earth is Square blog

    PUBLIC NOTICE AS REQUIRED BY LAW: Any use of this forum post, in any manner whatsoever, will increase the amount of disorder in the universe. Although no liability is implied herein, the consumer is warned that this process will ultimately lead to the heat death of the universe.


    • #17
      I tried to build Worldwind 1.3.2 (release archive) with nant rc3 but ran into trouble.

      [solution] PluginSDK\Icon.cs(172,32): error CS0117: 'Microsoft.DirectX.Direct3D
      .Font' does not contain a definition for 'MeasureString'
      [solution] PluginSDK\TiledPlacenameSet.cs(351, 39): error CS0117: 'Microsoft.Dir
      ectX.Direct3D.Font' does not contain a definition for 'MeasureString'
      [solution] Build failed.
      [solution] Project 'PluginSDK' failed!
      BUILD FAILED - 6 non-fatal error(s), 0 warning(s)

      I assumed I needed a later version of the DirectX SDK but found out that
      versions of the directx SDK after April 2005 will not install on Windows 2000.

      The April 2005 SDK is a couple of versions olded than current (Aug 2005).
      I tried Feb 2005 SDK and the latest World Wind on CVS same results.

      That said, whats the correct version of the Direct X SDK to use ?



      • #18
        so have people been able to succefully make stable builds of ww without I have a school lisence for it but would rather use something free
        My Webpage


        • #19
          Adam did with older builds, but I don't know about the latest ones.


          • #20
            Originally posted by bull@Sep 19 2005, 03:30 PM
            Adam did with older builds, but I don't know about the latest ones.
            I was successfully building with NAnt and the February SDK, up through 1.3.1 . . .

            I thought that I had also built 1.3.2, but now I am not so sure. The problem described above sounds related (albeit different) to some trouble I have had with CVS builds recently. I thought it was due to a change in code and method/solution for building that occurred after 1.3.2 development, but now I realize that it could be part of 1.3.2 as well, since I was spoiled with the nightlies/etc there for a while, and only when I tried 1.3.3 did I have any problems.

            Honestly don't know what to say, except that I believe when they switched things up a little, they still intended for N'Ant, etc build support- For me, it (1.3.3) does build, but whether I use Vis Studio or N'Ant, it has been doing some strange things with video rendering, and object creation?/writing to the screen, etc. I know so little, I can't even describe my problem From what I understand, certain recent issues should be resolved soon or already, if it wasn't just my inexperience to begin with. But I don't know about the issues which might come up building 1.3.2 -sorry. I think a couple of weeks might serve to clear some things up . . .

            I also heard a rumor that the June? SDK will build current HEAD (1.3.3, I am guessing?), so that may be worth a try. August- I doubt that is necessary at this point. Strange, no Win2k support past April SDK? Something to do with alpha-blending, maybe, or Microsoft's software euthanasia policies?
            Good luck
            or ask in IRC
            An excellent map projection reference


            • #21
              I tried the 1.3.1 (release archive) and had the same problem. (measure...

              I now think it is a NANT/NETFramework/Direct X issue on my system.
              The -debug switch for NANT has given me a bunch of stuff to look at.



              • #22
                I got NANT to build WorldWind 1.3.1 and 1.3.2 by changing the
       and scripts.

                <property name="dotnetdir" value="C:&#092;WINDOWS&#092;Microsoft.NE T"/>
                <property name="dotnetdir" value="&#036;{environment::get-variable(&#39;SystemRoot&#39}&#092;Microsoft.NET"/>

                The changed script should work for XP and WIN2K.

                To sum up I used
                DirectX 9 (April 2005) SDK
                Net FrameWork 1.1
                and NANT 0.85 rc3



                • #23
                  If anyone was having problems compiling 1.3.3 from CVS with Nant, I have fixed the LayerSet.csproj and checked it in on the 25th. (The GUID was different than the one in the .sln file)
                  Adam Hill - .NET and GIS Guy
                  Thregecy Inc. ::: TheBigPixel
                  Hack #24 - World Wind


                  • #24
                    Please Help :(
                    I try to bild the WW using nant in Windows Xp and I receive this Error "net-1.1 framework is not available or not configured"

                    I have already installed 1.1 and my Winddows XP is installed in D: I Changed the Property Values of the Default.Build and the Default.release.Build to
                    "D:&#092;WINDOWS&#092;Microsoft.NET" and later to "&#036;{environment::get-variable(&#39;SystemRoot&#39}&#092;Microsoft.NET" but nothing helped.
                    Can someone please help?


                    • #25
                      How to compile using 2003?

                      I've visual 2003; the source compiles anyhow but desired output is not recieved. The worldwind executes like a blueprint of outer window with no functionality.. where am I wrong?


                      • #26
                        Not sure I had the same thing when I did a clean checkout yesterday, I'll investigate.


                        • #27
                          440 meg, changing files and NAnt .85(the latest) does not work with .NET 2.0.

                          vc# 2005 express is a free download, works with .NET 1.1 or 2.0.
                          The MS PlatformSDK can be downloaded or on a CD from MS for shipping and handling, $10.

                          Very new to ms vc#, used to C++ and Python, there must be a reason to goto all this and probably makes sense.

                          Maybe $$$, not supposed to use vc# express for comercial purposes?


                          • #28
                            You can use VC# Express 2005 for anything you want. I'm not sure about it being able to do .Net 1.1 though...I've been using it since the first beta and it's always been .Net 2.0. Not a problem now because we're at WW1.4 for .Net 2.0.

                            "No Silicon Heaven?! Preposterous!...where would all the calculators go?"


                            • #29
                              * In your editor window you should now see something like the following.

                              If you don't see it, double click "Tutorial1" or the name of your class in the tree to open it in the editor.


                              • #30
                                thanks for the post, very helpful for someone who dosent know code.

                                thanks again
                                Magic Tricks