Results 1 to 3 of 3

Thread: WMS Tiff layer

  1. #1
    Junior Member
    Join Date
    Mar 2012
    Posts
    5

    Default WMS Tiff layer

    Hi
    i want to publish an image in tiff format under WW Server. I've created a new layer with the configuration file tiff.xml (attachements).
    When WW server start up logs:

    FINE: Discovery Task: New layer configuration found: TIFF/tiff.xml
    Mar 21, 2012 11:18:56 AM gov.nasa.worldwind.servers.wms.BasicMapR egistry doAdd
    INFO: Initializing mapsource tiff ...
    Mar 21, 2012 11:18:56 AM gov.nasa.worldwind.servers.wms.generator s.WorldWindTiledLayer initialize
    INFO: WorldWindTiledLayer:initialize(): started...
    Mar 21, 2012 11:18:56 AM gov.nasa.worldwind.servers.wms.generator s.WorldWindTiledLayer initialize
    INFO: WorldWindTiledLayer:initialize(): status=Done! type=imagery with coverage=(33.245°, 44.0°), (33.316°, 44.338°)
    Mar 21, 2012 11:18:56 AM gov.nasa.worldwind.servers.wms.BasicMapR egistry doAdd
    INFO: Initializition of mapsource tiff was successful.
    Mar 21, 2012 11:18:56 AM gov.nasa.worldwind.servers.wms.BasicMapR egistry doLayerAdded
    INFO: Layer TIFF/tiff.xml added


    It seems it's all ok, but when i tried to get the image, i've the following error:

    FINE: Thread [16]: Server App=NASA WorldWind WMS Imagery Server, { waiting time: 0 msec; execution time=2 msec; total time=2 msec; }
    Mar 21, 2012 11:21:34 AM gov.nasa.worldwind.servers.wms.generator s.WorldWindTiledLayer$BasicServiceInstan ce serviceRequest
    SEVERE: The WMS request failed: {0}
    java.lang.NullPointerException
    at gov.nasa.worldwind.servers.wms.generator s.BasicTileCacheMosaicer.assembleTiles(U nknown Source)
    at gov.nasa.worldwind.servers.wms.generator s.BasicTileCacheMosaicer.mosaicBestAvail ableTiles(Unknown Source)
    at gov.nasa.worldwind.servers.wms.generator s.WorldWindTiledLayer$BasicServiceInstan ce.doServiceRequest(Unknown Source)
    at gov.nasa.worldwind.servers.wms.generator s.WorldWindTiledLayer$BasicServiceInstan ce.serviceRequest(Unknown Source)
    at gov.nasa.worldwind.servers.wms.WMSGetMap Request.service(Unknown Source)
    at gov.nasa.worldwind.servers.app.WMSServer Application.doGet(Unknown Source)
    at gov.nasa.worldwind.servers.app.BasicHttp ServerApplication.doService(Unknown Source)
    at gov.nasa.worldwind.servers.app.BasicServ erApplication.service(Unknown Source)
    at gov.nasa.worldwind.servers.app.ServerWor kerThread.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor. runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$ Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:679)

    Any idea?

    Thank you!
    Attached Files Attached Files

  2. #2
    Unregistered
    Guest

    Default How to add extra images in worldwind java

    I have the same question,

    and I want to know how to determine the "LevelZeroTileDelta", from the tiff.txt ,the auther said
    " <LevelZeroTileDelta>
    <LatLon latitude="36.0" longitude="36.0" units="degrees"/>"
    so,I want to know the "36.0" depend on what?

  3. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    18

    Default

    Sorry to the OP, I'm facing problems serving the data myself. The levelzerotiledelta tag is used to determine how many degrees of latitude and longitude each of the tiles cover. For WW, 36x36 on level 0 is standard, creating 50 tiles, laid out in 5 rows and 10 columns.
    Here is a slightly more detailed explanation.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •