Results 1 to 10 of 10

Thread: JOGL 1.1 incompatibility with Java 6u31

Hybrid View

  1. #1

    Default JOGL 1.1 incompatibility with Java 6u31

    Our World Wind application has fatal problems with JOGL when updating to Java 6u31. Our workaround has been to restore to Java 6u30. However, government networks are requiring an update to Java 6u31 which breaks the application. Has anyone else experienced this problem or does anyone have a workaround for this problem?

    Thanks,
    Dale

  2. #2

    Default

    The problem is caused by Oracle modifying certificates and the certificates that the JOGL jars were signed with are no longer valid which causes a fatal error in World Wind that cannot be rectified.

    I have verified this with the World Wind example applet and application template on the World Wind demo page.

    This will potentially impact all DoD instances of World Wind during the next couple of days as the networks are updated as directed by Information Assurance (IA).

    Right now the only work around that we know of is to revert to 6u30.

    I am going to try replacing the JOGL jars with the latest from download.java.net and see if the signing certificates have been updated.

    Thanks,
    FishNBrewDude

  3. #3
    WWJ Technical Manager
    Join Date
    May 2007
    Location
    Seattle
    Posts
    1,119

    Default

    We're looking into it. Should have an answer in the morning (PST).

  4. #4

    Default Potential solution to JOGL problem verified on isolated network

    We were able to reproduce the problem on our isolated system and we resolved by resigning the JOGL and GLUEGEN with a valid certificate.

    We did not need to rebuild JOGL.

    I would assume that NASA will need to host resigned JARS for the demos to work. I have also posted the problem on the jogamp forum (http://forum.jogamp.org/JOGL-broken-...td3791268.html) and hopefully they will fix JOGL at the source.

    Thanks,
    FishNBrewDude

  5. #5
    WWJ Technical Manager
    Join Date
    May 2007
    Location
    Seattle
    Posts
    1,119

    Default

    We have just re-signed all the jogl related jar files and installed them at our webstart site. The certificate used is NASA World Wind's, not Sun's or Oracle's. This appears to eliminate the certificate issue. You shouldn't have to do anything to utilize this change, but new libs should download the next time you run a WW webstart application or applet. If you still have problems, try clearing your Java cache of old jogl and gluegen resources.

    Having said this, we notice that the applets on the demo page don't work. But we don't think it's because of the certificate issue.

  6. #6

    Default

    Thanks tag.

    Would it be possible for you to provide pack.gz version of the signed jar files?

    Because we package World Wind as an applet the packed versions of the files provide for faster download times and a better user experience. Sun provided packed versions of the jogl.jar and gluegen.jar. We cannot do that with the provided files because it corrupts the signatures.

    The process to do this would be
    1. pack200 -r
    2. jarsigner
    3. pack200

    This will produce both a signed jar file and a signed jar and a signed compressed jar.pack.gz

    Thanks,
    FishNBrewDude

  7. #7
    WWJ Technical Manager
    Join Date
    May 2007
    Location
    Seattle
    Posts
    1,119

    Default

    We can do this.

    I'm assuming that gluegen-rt.jar (25 kb) is too small to matter, and that the jogl-natives and gluegen-natives would not benefit and therefore don't need it. Let me know if you think otherwise.

  8. #8

    Default

    That is correct, only jogl.jar is required now that you mention it.

    Thanks.

  9. #9
    NASA Employee Randy Kim's Avatar
    Join Date
    Aug 2004
    Location
    Moffett Field, CA
    Posts
    121

    Default

    jogl.jar.pack.gz has been posted to the same directory in
    http://worldwind.arc.nasa.gov/java/j...gl.jar.pack.gz

  10. #10

    Default JOGL Question

    Thanks, you guys are awesome!

    This problem resulted in me posting an issue on the jogamp forum.
    http://forum.jogamp.org/JOGL-broken-...td3791268.html.

    This resulted in an interesting discussion, and the final post identified a concern by the JOGL community that World Wind uses a version of JOGL that is no longer supported and that JOGL 2.0 is supported by JOGAMP.

    He also stated the possibility that JOGL 1.1 might not work on Windows 8.

    Are there any plans for NASA to upgrade World Wind to JOGL 2.0?

    Thanks,
    FishNBrewDude

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to setup WWJ
    By Hervé in forum Development Help
    Replies: 104
    Last Post: 12-18-2014, 08:16 AM
  2. wwj and java 7
    By workingDog in forum Development Help
    Replies: 6
    Last Post: 02-29-2012, 03:30 PM
  3. What version of JOGL is this with WWJ 1.6??
    By naql in forum Development Help
    Replies: 2
    Last Post: 06-22-2009, 05:22 PM
  4. my java console
    By justime8 in forum Technical Support
    Replies: 2
    Last Post: 02-02-2009, 04:31 PM
  5. World Wind Java 0.2.0: which JOGL and gluegen versions?
    By fabrizio.giudici in forum Development Help
    Replies: 2
    Last Post: 06-07-2007, 06:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •