Results 1 to 3 of 3

Thread: DSTile missing files error

  1. #1
    Junior Member
    Join Date
    May 2009
    Posts
    2

    Default DSTile missing files error

    Hi DSTile gurus,

    I've run into an odd problem with what_nick's win32 port of DSTile. It seems to skip over several tiles that contains almost solid colors or very near black images. Specifically, I'm tiling the BMNG data and it will not produce a tile for specific areas in the ocean where the whole tile is solid dark blue.

    This entire exercise is more of a learning process for me, and in the last few weeks I've gone from a new user to tiling for WW. Here's the blow by blow of what I'm doing:

    1. I've got the WW cache pack of BMNG tiles as a reference. 17,051 files for January.

    2. I went and downloaded the "world.topo.bathy.200401.3x21600x21600.p anels.png" source files from NASA and wanted to re-tile them.

    3. Using gdal_translate, I reprojected them as GeoTIFF files using the following commands:

    Code:
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr -180 90 -90   0 world.topo.bathy.200401.3x21600x21600.A1.png A1.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr -90  90   0   0 world.topo.bathy.200401.3x21600x21600.B1.png B1.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr   0  90  90   0 world.topo.bathy.200401.3x21600x21600.C1.png C1.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr  90  90 180   0 world.topo.bathy.200401.3x21600x21600.D1.png D1.tif
    
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr -180  0 -90 -90 world.topo.bathy.200401.3x21600x21600.A2.png A2.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr  -90  0   0 -90 world.topo.bathy.200401.3x21600x21600.B2.png B2.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr    0  0  90 -90 world.topo.bathy.200401.3x21600x21600.C2.png C2.tif
    gdal_translate -of GTiff -a_srs "+proj=latlong +datum=WGS84" -a_ullr   90  0 180 -90 world.topo.bathy.200401.3x21600x21600.D2.png D2.tif
    So far, so good. The gdalinfo now gave me the proper locations for each of the GeoTIFF files produced.

    4. Now I fired up DSTile (using FWTools version 2.3.0) and used this command:

    Code:
    dstile tile --lztsd 36 --wwcache --png --overviews output_tiles A1.tif A2.tif B1.tif B2.tif C1.tif C2.tif D1.tif D2.tif
    Once the tiling was finished, most all the tiles perfectly matched the original cache pack, except a few were missing. My tile operation produced only 16,851 files.

    I went to compare a few tiles and found that most of the tiles there were not produced are in the middle of the ocean. The jpg version in the tile pack show these tiles are very plain in content. Some are almost completely full of blue pixels (colored r:2 g:5 b:20) with maybe 5 pixels of a slightly different shade blue (colored r:2 g:5 b:22).

    A few examples can be found in this folder: "BMNG (Shaded + Bathymetry) Tiled - 1.2004\4\0012". There should be 160 tiles, but my test only produced 132 tiles. A few that are missing include: 0012_0025, 0012_0029, 0012_0030, and 0012_3032 to 0012_0035. Several other folders contain a few missing files here and there around the globe, but they all share the same characteristic of having little to no data other than a solid color.

    I've tried re-tiling using jpg and got the exact same results. Same files are missing from level 4.
    I've tried re-tiling using FWTools 1.4.2 (the same version DSTile was built alongside), but with the same results again.

    What am I missing here? Why does DSTile or the gdal tools it uses not output those tiles?


    Oh, and "Hi" World Wind Central. I must have spent the better part of the last 2 weeks reading postings here learning about Tiling and Serving data for WW. Awesome collection of knowledge!

  2. #2
    Administrator
    Join Date
    May 2006
    Posts
    32

    Default

    Colors below certain value are used to indicate transparent areas and if a tile would be all transparent it is omitted. You need to either preprocess the input data to not contain near-black or modify dstile sources to reduce the color value.

  3. #3
    Junior Member
    Join Date
    May 2009
    Posts
    2

    Default

    I decided to try and modify dstile for this purpose, but I can't seem to get it to compile and run in VC 2008 Express edition.

    I haven't made any changes to what_nick's code yet. I'm just trying to compile his version and get it to work. Currently the binary that I compile just crashes when I try to use it. what_nick's pre-compiled binary works fine with the same syntax.

    If anyone knows why my compiles don't work or can help me with getting what_nick's windows port to compile, I'd be grateful!

    Here's what I originally wrote:
    I'm trying to compile DSTile using the source you posted to these forums along with the GUI you started working on.

    I've also used your binaries to make sure there isn't some kind of syntax error. Tiling works great with your binary version.

    So far, I haven't had much luck with getting my compiled version to actually run. It prints out the various command flags, then prints the first File name and the 0% indicator, then crashes.

    I've tried installing various versions of FWTools. I notice you used both 1.2.2 and 1.3.5 in your VC options for debug and release. I've even tried the newest 2.3.0, but with no difference.

    Are there anything I'm missing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DSTile Error: permission denied
    By arun.kumar in forum Image Serving & GIS
    Replies: 6
    Last Post: 11-17-2011, 06:08 AM
  2. Reg compiling the source code
    By Raj in forum Developers' Corner
    Replies: 10
    Last Post: 08-26-2008, 07:58 PM
  3. WorldWind.Log for V1.4Beta
    By James_In_Utah in forum Developers' Corner
    Replies: 1
    Last Post: 12-30-2006, 01:58 AM
  4. Snapshot Error
    By jediwashuu in forum Bug Reports
    Replies: 4
    Last Post: 11-06-2004, 04:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •